Blog

Scrivete qui domande, commenti, consigli e nuove idee. Per scrivere basta il nome o un soprannome come “io” o “pippo”, lasciando vuote le altre caselle.

Aggiungere anche la “Email” serve solo per distinguersi con certezza. Se volete aggiungere la mail fatelo con fiducia, noi abbiamo di meglio da fare, che raccogliere indirizzi a scopo di spam.

Il Blog non è tutto in questa pagina, andate sul menu “Blog” e scegliete un argomento.

Se non riuscite a trovare una sezione del blog appropriata, scrivete in questa pagina e provvederemo noi, a trovare la sezione giusta, oppure a crearne una nuova.


Inserire immagini e evidenziare i messaggi del blog

Inserire una immagine:

<img src="https://www.xxxx.yyyy.zzzz.jpg" alt="Image description"/>

Evidenziare una parte del testo:

<span style="background-color: #ffff99;">TESTO DA EVIDENZIARE</span>

Sentitevi liberi di fare errori e esperimenti nei post. Se qualcosa va storto, basta scrivere un secondo post, con le correzioni da fare. Faremo noi le correzioni e infine cancelleremo i messaggi di servizio.

  1. CLAUDIO says:

    SE PUO’ ESSERE UTILE AGGIUNGO CHE ANCHE CHIUDENDO IL CNC FALLATO APPENA APERTO RIAPRENDOLO QUESTO E’ ANCORA FALLATO PER RISTABILIRE IL TUTTO DEVO SCOLLEGAGE USB E SPEGERE LA CNC

    SALUTI

  2. CLAUDIO says:

    BUONGIORNO
    HO RISOLTO UTILIZZANDO CNC V4.9 E HAL V7.0
    CHE AVEVO INSTALLATO SU UN VECCHIO PC CON WINDOWS 7
    HO TRASFERITO LE RELATIVE CARTELLE SUL PC CON WINDOWS 10 E FUNZIONA
    SICCOME SUL VECCIO PC AVEVO ENTRAMBE LE VERSIONI EVIDENTEMENTE USAVO LA VECCHIA ( E’ UN PO’ CHE NON USAVO QUESTA CNC E FORSE N0ON RICORDAVO IL PROBLEMA ).NON SO PROBABILMENTE QUALCOSA NEL SW SFUGGE.
    DI NUOVO SALUTI E GRAZIE

  3. Luigi says:

    Buongiorno! houn theremino e ho appena scaricato il programma, ammetto che mi trovo un attimo confuso dalla sua configurazione, esiste qualcuno che potrebbe aiutarmi? Chi posso contatttare?

    • Livio says:

      Scrivi qui le domande.
      Oppure scrivimi a engineering chiocciola theremino punto com
      Così poi magari ti potrei aiutare anche via telefono, o Skype o AnyDesk.

      • Luigi says:

        Mail inviata!
        Grazie mille in anticipo!

        • Livio says:

          Con la condivisione dello schermo di Skype farlo funzionare è stato abbastanza facile.

          Per chi avesse problemi simili ricordatevi di utilizzare “Load config.”, tanto per iniziare a fare qualche suono e poi leggete il file di istruzioni.

  4. Giacomo says:

    Buonasera. Avrei necessità di un’informazione. Ho uno IOTmodule ESP32 – Picokit V4 che utilizzo per leggere sensori ambientali. La versione del firmware è la 182-1. Lo alimento con un powerbank a 5 V da 5000 mAh del tipo per cellulari. Il powerbank permette (da quello che dice il costruttore) la carica di un cellulare e la sua contemporanea ricarica. Il tutto funziona egregiamente. L’unico problema che riscontro è durante la ricarica del powerbank o meglio, nel momento in cui stacco il caricabatterie di rete quando il powerbank si è ricaricato. In quel momento, lo IotHAL (ver. 1.4) si disconnette dallo IOTmodule e compare la scritta in rosso (a volte anche in azzurro) che il modulo ha perso la configurazione. Ho come l’impressione che, con il distacco del caricabatterie di rete, il powerbanck si riavvii. Mi basta però cliccare su “Recognize” dello IotHAL per far ripartire il tutto normalmente. Avete qualche idea su cosa possa provocare il distacco tra iotmodule e IotHAL? Serve qualche accorgimento software o hardware? Grazie

    • Livio says:

      Nel momento in cui si distacca il caricabatterie il PowerBank che stai utilizzando fa delle commutazioni interne e quindi interrompe per un istante il 5 volt di uscita.

      Non è detto che tutti i powerbank facciano questo “difetto”, potresti vedere se ne trovi uno che non interrompe la tensione di uscita.

      Ho appena provato con uno di quelli da due batterie e con l’interruttore da un lato che accende un LED e si comporta anche peggio del tuo. Per tutto il tempo che riceve il 5 volt di ricarica manda allo ESP32 una tensione di soli 3.5 volt, che naturalmente non basta e lo ESP32 si scollega.

      Ho provato anche uno di quelli rettangolari, da una batteria sola, che lampeggiano rosso e blu durante la ricarica, e anche lui smette di alimentare durante la ricarica.

      Se non ne trovi nessuno che mantenga sempre attiva la comunicazione e se questa funzionalità è proprio importante nel tuo caso allora potresti:
      – Utilizzare un qualunque PowerBank (quindi anche il tuo attuale)
      – Derivare due fili rosso e nero direttamente dal + e – delle batterie (farli uscire da un buchino ma attenzione che questi due fili non si tocchino mai perché le batterie potrebbero patire molto, e i fili scaldarsi e addirittura prendere fuoco) (eventualmente sarebbe bene aggiungere un fusibile da 2 ampere in serie al filo positivo e vicino alle batterie)
      – Collegare i due fili a un alimentatore Step-Up che produca un 5 volt stabile partendo dal 3.7…4.2 volt delle batterie.

      Puoi trovare facilmente step-up adatti su eBay, ad esempio questo:
      https://www.ebay.it/sch/i.html?_from=R40&_nkw=174466904903

      Comunque lo IotHAL dovrebbe (se possibile) ricollegarsi da solo. Ho appena provato la versione 1.4 e si ricollega, se il tuo non lo fa forse stai utilizzando una versione precedente. O forse la alimentazione dello ESP32 manca per un tempo troppo breve o non torna con abbastanza tensione e lo ESP32 non si resetta bene o non riesce più a ricollegarsi alla rete.

      Dopo che lo IotHAL si è ricollegato rimane la scritta “The IotModule has lost the configuration” che serve per sapere che in qualche momento passato la configurazione è stata persa. Ma la casella FPS dovrebbe indicare una frequenza di comunicazione (non zero) e non dovrebbe più essere con lo sfondo rosso. E questo indica che il tutto è tornato pienamente operativo.

      —-

      Attenzione ai cavetti che si usano per alimentare lo ESP32 !!!

      Proprio oggi provando i Power Bank ho scoperto che i cavetti contano molto.
      La tensione che partiva dal PowerBank era di circa 5 volt
      – Con cavetto nero rotondo, lungo un metro, la tensione sullo ESP32 era di 4.74 V
      – Con cavetto bianco piatto, lungo 30 cm, la tensione sullo ESP32 era di 4.2 .. 4.4 V

      Mi aspettavo che il cavetto corto andasse meglio invece no,
      va così male che lo ESP32 ogni tanto si scollega.

      Dopo un ora il PowerBank si era un po’ scaricato e dava solo 4.8 V
      La tensione con il cavetto corto si abbassava fino a circa 4 volt,
      e naturalmente lo ESP32 si scollegava e non andava proprio più.

      Allora ho provato a cambiare cavetto e mettere quello nero.
      La tensione sullo ESP32 è risalita a 4.6 V
      E adesso sono ore che va !

      Per cui prima di dare la colpa ai PowerBank o alle batterie che durano poco.
      Cercate i cavetti giusti!!!

  5. Gabriele says:

    Buonasera,

    sono un chimico e mi sono avvicinato da poco al mondo di Theremino. In particolare, mi interessa la spettrometria gamma e trovo veramente affascinante, anche in termini didattici, la possibilità di combinare MCA con THEREMIN (in configurazione “radioactivity”) per ascoltare la “musica” degli isotopi radioattivi. Ho fatto diverse prove con un rivelatore NaI(Tl) acquistato in rete e il tutto funziona molto bene, ma mi chiedevo quali impostazioni utilizzare su THEREMIN per differenziare il più possibile la musica di un isotopo da quella di un altro.
    Faccio presente che in materia di audio le mie competenze sono ben poche. Comunque sia, ho notato che nella configurazione “radioactivity” il sistema utilizza di fatto solo pochi dei tasti musicali virtuali: di conseguenza, due isotopi riescono a distinguersi facilmente solo se hanno picchi ben distanti (ad esempio Cs-137 e Am-241, con picchi principali rispettivamente a 662 e 59 keV), mentre, ad esempio, diventa arduo apprezzare la differenza fra una sorgente di Am-241 e il Th-234 di un piatto Fiestaware (picco a 92 keV). Ho provato a smanettare un po’, per esempio cambiando gli accordi qualcosa si riesce a migliorare, ma non di molto. Chiedo quindi se avete qualche indicazione utile da darmi e vi ringrazio in ogni caso.

    • Livio says:

      Mi spiace ma non abbiamo fatto molto di più di quello che c’è nella configurazione “Radioactivity”. Se sei riuscito a farla suonare e anche a migliorarla un po’ probabilmente ora ne sai anche più di noi.

      Probabilmente con l’audio più di tanto non si può fare, e non potrai mai avere la risoluzione ottenibile guardando un grafico.

      Forse si potrebbe fare una applicazione nel linguaggio Theremino_Automation, o addirittura con VbNet, la quale potrebbe leggere gli Slot di uscita dello MCA fare ragionamenti complessi, linearizzare i dati o renderli logaritmici, selezionare le note da usare, usare note diverse per ogni isotopo… ecc… E alla fine scrivere in altri Slot i valori processati che farebbero suonare la applicazione Theremin.

      Ma la domanda è: ne varrebbe la pena? In fondo “ascoltare” è solo una curiosità. Mentre “guardare” funziona molto meglio. Per cui non ci perderei troppo tempo, lo utilizzerei come è adesso e le analisi vere le farei con i grafici.

      • Gabriele says:

        Buonasera Livio,

        grazie per la tua pronta risposta. Concordo con te: la musica non è altro che una curiosità e ciò che conta realmente sono i grafici degli spettri! Il mio interesse per l’aspetto audio nasce più che altro per rendere l’insegnamento della radioattività più interessante per i miei alunni.
        Molto interessante quello che dici circa la possibilità di creare un’applicazione in Theremino_Automation, proverò a rifletterci ed eventualmente tornerò a disturbarti!
        Grazie per tutto il lavoro meraviglioso che fate a beneficio di tanti appassionati!!!

        • Livio says:

          Grazie a te per i complimenti. E chiedi pure ogni volta che ti serve, non è un disturbo. E grazie di scrivere qui nel blog invece di mandarci mail private. Ogni messaggio qui nel blog può essere di aiuto per tutti.

          E auguri per le tue lezioni “radioattive”. che sicuramente provocheranno un interesse speciale nei ragazzi, sempre attratti dai pericoli e dalle cose proibite. Se già non lo hai fatto ti consiglio di comprare chili di cloruro di potassio e di pietra pomice. Sono del tutto in libera vendita e li puoi anche mangiare. Ma quando ne hai dei chili producono un bel po’ di radioattività.

  6. Giacomo Rucci says:

    Buonasera, avrei necessità di un aiutino. Seguendo un vostro consiglio, ho “manipolato” un vostro programmino, il Theremino_Logger, per strutturarlo in maniera tale da utilizzarlo per un progetto di ricerca da presentare al mio staff al fine di impostare una metodologia open source per la misura del metabolismo energetico di attività lavorative. Da utilizzare per le valutazioni del rischio microclimatico in ambienti di lavoro. Ora però questo programma, ancora in fase di completamento, funziona sul mio pc di casa con Windows 10 ma non su quello del mio ufficio che monta sempre Windows 10 e framework 3.5. In pratica il .exe non si avvia al doppioclick. Premetto che tutti gli applicativi vostri originali, compreso il Theremino_Logger, invece funzionano perfettamente sul pc del mio ufficio. Vi viene in mente qualcosa che sbaglio? Se vi devo mandare il sorgente, indicatemi cortesemente a quale email. Grazie

    • Livio says:

      Ciao, lo aggiusteremo facilmente

      Scrivi a engineering chiocciola theremino punto com
      oppure chiamami su skype dove mi trovi come livio_enrico

      E questo vale anche per altri, chiamate pure, siamo qui apposta.

  7. Antonio says:

    Salve Livio, sono alle prese con un progetto in cui necessito di un misurare la corrente in modo preciso e stabile,e per far ciò vorrei utilizzare il sensore di tensione-corrente (versione differenziale) proposto da voi. I parametri da misurare sono tensione max +/-15V e corrente max 1A. Nel vostro progetto quando si parla di aumentare il modo comune tollerabile a +/- 300V ( in cui mi ritrovo il range +/-15V) si propone di sostituire R2 e R3 con resistori da 100 Mohm ma tra le parentesi noto che è scritto (R3, R4, R5 e R6 = 1 Mega e trimmer = 47k, come da schema), a questo punto qualcosa non torna con R3, quale valore adottare? Per la misura della corrente nel range richiesto adotterò R0 da 0.1 Ohm. Il sensore proposto è sensibile e stabile? Ho già provato, purtroppo, con altri sensori ma la misura della corrente nel range a me utile (50-500mA) non è stabile. Grazie per tutti i suggerimenti che saprete fornirmi. Vi seguo ormai da anni e ancora una volta complimenti per il vostro sito e la professionalità dimostrata.

  8. Livio says:

    Non capisco cosa non torna
    – R3, R4, R5 e R6 = 1 Mega
    – trimmer = 47k
    – Con R1 e R2 da 10 mega ottieni un modo comune di +/- 33 V (non ti basterebbe?)
    – Con R1 e R2 da 100 mega ottieni un modo comune di +/- 330 V

    Non ti basterebbero +/- 33 V di modo comune ?
    Tieni conto che la precisione diminuisce se aumenti di valore R1 e R2
    Per cui con fondo scala di +/-33V avrai una risoluzione e precisione intorno ai 10 mV
    Mentre con fondo scala di +/-330V avrai una risoluzione e precisione intorno ai 100 mV

    Riguardo al “sensibile” vale sempre la stessa legge di prima, cioè che puoi avere una risoluzione (quindi sensibilità) pari a circa un decimillesimo del fondo scala.

    E riguardo alla stabilità i numeri balleranno anche loro di quell’ordine di grandezza (un millesimo del fondo scala al massimo), ma se farai la media mobile nel tempo potrai anche aumentare di molto la stabilità. Se leggi i valori con il nostro Master e la nostra applicazione HAL potrai regolare il filtro per ottenere una stabilità anche molto maggiore.

    —————–

    Per ottenere precisioni e stabilità decisamente maggiori potresti usare l’ADC 24.
    Costa un po’ ma non avresti più bisogno di questo circuito e nemmeno di tarare i trimmer.
    Leggi le sue istruzioni per vedere cosa può fare:
    https://www.theremino.com/hardware/adapters#adc24

    Per misurare la corrente dovrai impostare un canale in differenziale e mettere i resistori giusti per le portate che ti servono.
    Non sto a farti i calcoli ma ci potrai arrivare anche da solo e poi basterà provare e se non andrà bene si tratterà solo di cambiare due resistori.

    • Antonio says:

      salve Livio,grazie per la celere risposta e i suggerimenti proposti.
      Nel progetto e scritto R2 eR3 da 100 MOhm e non R1 e R2. Dal progetto:
      “Aumentare il modo comune tollerabile a +/- 300 Volt
      Sostituendo R2 e R3 con resistori da 100 Mega Ohm (R3, R4, R5 e R6 = 1 Mega e trimmer = 47k, come da schema), si ottengono i seguenti range di tensione:…” Il valore di R3 e ripetuto due volte. Se sono in errore, ti porgo le mie scuse sin d’ora. Ti auguro un buon sabato.

      • Livio says:

        Avevi ragione, era sbagliato in tre posti, grazie di aver trovato questi errori.
        Ora dovrebbe essere a posto ma se trovi altri errori scrivici.
        Ciao

        P.S.
        Dovesse succedere che vedi ancora la pagina di prima, allora devi svuotare la cache del browser.

  9. Antonio says:

    Salve Livio, credo ci sia un errore nella prima tabella o seconda tabella:
    “Con i valori di questo schema il circuito tollera tensioni di modo comune fino a +/- 33 Volt e con la sola sostituzione di R9 si ottengono i seguenti range di tensione:

    Tensioni da -10 mV a +10 mV con risoluzione di 0.3 micro Volt (R9 = 1.5Mega)
    Tensioni da -15 mV a +15 mV con risoluzione di 0.5 micro Volt (R9 = 1Mega)
    Tensioni da -30 mV a +30 mV con risoluzione di 1 micro Volt (R9 = 470k)
    Tensioni da -100 mV a +100 mV con risoluzione di 3 micro Volt (R9 = 150k)
    Tensioni da -150 mV a +150 mV con risoluzione di 5 micro Volt (R9 = 100k)
    Tensioni da -300 mV a +300 mV con risoluzione di 10 micro Volt (R9 = 47k)
    Tensioni da -1 V a +1 V con risoluzione di 30 micro Volt (R9 = 15k)
    Tensioni da -1.5 V a +1.5 V con risoluzione di 50 micro Volt (R9 = 10k)
    Tensioni da -3 V a +3 V con risoluzione di 100 micro Volt (R9 = 0)
    ” il range di tensione si ferma a 3V e non 33V come affermato sopra! qui R1 e R2 sono come da schema 10MOhm e R3=R4=R5=R6=1MOhm.
    Nella seconda tabella:
    “Ridurre il modo comune tollerabile a +/- 3.3 Volt
    Sostituendo R3, R4, R5 e R6 con resistori da 10 MOhm e i due trimmer da 470 KOhm, si ottengono i seguenti range di tensione:

    Tensioni da -10 mV a +10 mV con risoluzione di 0.3 micro Volt (R9 = 150k)
    Tensioni da -15 mV a +15 mV con risoluzione di 0.5 micro Volt (R9 = 100k)
    Tensioni da -30 mV a +30 mV con risoluzione di 1 micro Volt (R9 = 47k)
    Tensioni da -100 mV a +100 mV con risoluzione di 3 micro Volt (R9 = 15k)
    Tensioni da -150 mV a +150 mV con risoluzione di 5 micro Volt (R9 = 10k)
    Tensioni da -300 mV a +300 mV con risoluzione di 10 micro Volt (R9 = 4.7k)
    Tensioni da -1 V a +1 V con risoluzione di 30 micro Volt (R9 = 1.5k)
    Tensioni da -1.5 V a +1.5 V con risoluzione di 50 micro Volt (R9 = 1k)
    Tensioni da -3 V a +3 V con risoluzione di 100 micro Volt (R9 = 0 ohm)

    quindi con valori di R1=R2=10MOhm e R3,R4,R5,R6=10MOhm ottengo sempre lo stesso range?
    Qualcosa non torna. Ecco perchè inizialmente proponevo per il range +/-15V con resistori da 100MOhm .Se ancora una volta sono in errore, perdonami.
    Una buona serata

    • Livio says:

      Nella seconda tabella R3, R4, R5 e R6, e anche i due trimmer, sono tutti aumentati di dieci volte. Quindi l’amplificazione del primo stadio è dieci volte maggiore e il circuito satura con modo comune di +/- 3.3V al posto che +/- 33V

      Ma con la seconda tabella si ottengono esattamente gli stessi range di tensione perché R9 viene ridotta di dieci volte (a destra di ogni riga tra parentesi).

      A me sembra giusto, scrivici di nuovo se non ti quadra.

  10. Massimo says:

    Buongiorno. Ho appena scoperto il progetto theremino, volevo capirne di più e fare dei test per imparare come funziona. Ho girato il sito, ma non ho trovato un percorso chiaro, un tutorial che mi segua passo-passo con semplici esempi per iniziare. Non ho trovato un libro che mi dia un percorso da seguire. Ho tentato di acquistare hardware, ma il sito http://www.store-ino.com non esiste più (ve lo segnalo anche per aggiornare il sito). Vengo dal mondo Arduino in cui, dopo aver spiegato le basi, si trovano i classici esempi: accendere un led, leggere un potenziometro o lo stato di un pulsante, pilotare un motore o un servo. Qui non riesco a capire quale hardware acquistare per poter fare queste cose, e soprattutto dove acquistarlo per non prendere bidonate. Mi serve un aiuto, grazie.

  11. Livio says:

    Questa conversazione è stata spostata qui dalla pagina delle novità che è bene lasciare libera per le novità.
    ———————————————————————–

    Cosimo Miccoli – 14/12/2021 at 21:58
    salve , ho da poco scoperto i vostri software mi sembrano ottimi. Sono appassionato di ricezione radio,ho scaricato Theremino SDR ma non riesco ad avviarlo, ho lanciato zadig, riavviato, ma niente. Uso tranquillamente SDRSharp, mi potreste dare qualche consiglio?
    saluti e grazie

    Livio – 15/12/2021 at 09:27
    In che senso “non si avvia” ?
    La applicazione non presenta la finestra sul desktop ?
    La applicazione si apre ma poi non si collega con il frontend ?

    Hai estratto i file dallo ZIP e li hai messi in una cartella tua ?
    E’ una cartella che non richiede permessi speciali ?
    Che sistema operativo usi ?

    Se non riesci contattami su Skype come livio_enrico
    (e all’occasione ricordami di cosa stavamo parlando…)

    Cosimo Miccoli – 15/12/2021 at 12:45
    Buongiorno Livio, a proposito dell SDR.L’applicazione si apre, al momento che schiaccio su Run, mi da la scritta ” RTL-SDR/USB is either not connected or its driver is not working properly”.
    Io comunque ho avviato più volte zadig. Uso windows 10, ho estratto i file dallo zip e ho avviato dalla sua cartella. Potrebbero mancare dei file nella cartella?
    Grazie

    Livio – 15/12/2021 at 13:42
    Nella cartella di ThereminoSDR ci dovrebbero essere sei DLL, un EXE e un INI (e anche una cartella DOCS ma non conta). Magari prova a cancellare l’INI e poi rilanciare l’EXE.

    Ho provato adesso per controllarlo con gli ultimi aggiornamenti di Windows 10 e ha funzionato subito.

    Che sia dovuto alla USB che non comunica bene?
    Prova a cambiare presa USB.
    Prova a avviare ThereminoSDR come amministratore.
    Controlla di impostare il tipo giusto con ZADIG (non ricordo bene ma mi sembra che c’erano due possibilità e forse WinUSB era la migliore…)

    Riprova SDRSharp, con lui funziona?
    Comunque è davvero strano, questa applicazione ha sempre funzionato a tutti.

    Potrebbe essere il tipo di ricevitore che non è compatibile?
    In tal caso l’unico modo di capire cosa succede sarebbe di chiamarmi su Skype e poi anche installare VisualStudio 2008 (CSharp) e poi farmi vedere che succede nel codice e che errore avviene.

    Cosimo Miccoli – 15/12/2021 at 18:36
    Buonasera Livio, non riesco a contattarti con skype, ho fatto tutte le prove che mi hai consigliato. Ma niente da fare Sdrsharp funziona benissimo e ho cambiato due SDR , compresa la porta Usb.
    Visualstudio non lo installa mi da ” Error occurred during setup “

    Livio – 15/12/2021 at 22:40
    Caspita, una bella serie di cose che non funzionano!

    Che poi non si installi nemmeno VisualStudio è davvero incredibile.

    Allora, il mio nick di skype è: livio_enrico
    Deve funzionare per forza, lo hai scritto tutto minuscolo e con l’underscore in mezzo ?
    Dammi il tuo nickname di skype o scrivimi a engineering chiocciola theremino punto com
    così poi ci scambiamo il numero di telefono.

    Comunque niente paura, quando riusciremo a comunicare faremo funzionare tutto, magari attraverso “chrome remote desktop”

  12. Alessandro Rosso says:

    Buongiorno.
    Uso theremino su fresa CNC mi trovo molto bene
    Sto ultimando una CNC con plasma.
    Il problema che tagliando lamiera molto sottile si deforma,quindi ci sarebbe la necessità di fare un azzeramento ogni qual volta fa un foro o taglia una sagoma.
    E possibile fare un azzeramento tipo pulsante ( calibra) con tastierino captativo ma inserendolo in un gcode.
    Grazie saluti

    • Livio says:

      Mi spiace, da GCode non si può fare, bisognerebbe modificare la applicazione CNC. Noi quest’anno non avremo tempo di farlo ma potrebbe farlo chiunque con un minimo di esperienza nella programmazione.

      Il mio consiglio è di trovare qualcuno che può fare questa modifica e di aiutarlo cominciando a fare delle prove manuali e individuare con precisione quali sono le operazioni da effettuare.
      – Basterebbe un comando GCode che preme il tasto “SetZeta HOME” ?
      – Poi ci vorrebbe una pausa per attendere la fine della operazione ?

  13. Alessandro Rosso says:

    Con G92enn non si può fare come se fosse un estrusore

    • Livio says:

      Scusa ma non ho capito, la tua era una domanda o una affermazione ?
      Proponi di usare il G92 (senza parametri) per premere il tasto “Set Zeta Home” come se lo premessi manualmente ?
      E poi magari aggiungere una pausa nel GCode con G04 .

      E fatto così funzionerebbe ?
      Hai provato a farlo manualmente per verificare se la sequenza che ho ipotizzato funzionerebbe ?

  14. Alessandro Rosso says:

    Si ho provato ma non lo riconosce G92 non

    • Livio says:

      Lo so che non lo riconosce.

      Infatti ho chiesto se hai provato a fare manualmente:
      – Un “Set zeta home” (come se venisse eseguito dal GCode)
      – E poi fare una pausa (come se il gcode eseguisse un G04)

      Facendo così riesci ad azzerare?

      Funzionerebbe ?

  15. Alessandro Rosso says:

    Set zeta home lo impostato a 10 mm sopra lo 0 pezzo
    Per azzerare uso calibrate z e si azzera molto bene

    • Livio says:

      Giusto!
      Ho sbagliato a scrivere “Set zeta home”, intendevo “Calibrate Z”

      Quindi fammi capire, potrebbe funzionare se…
      – Se un G92 (senza parametri) premesse il tasto “Calibrate Z” e quindi lo facesse mentre il GCode cammina.
      – E se poi tu aggiungessi una pausa G04 nel GCode per dare tempo all’azzeramento di terminare.

      Ma come farebbe ad azzerare da solo?
      Non devi ogni volta posizionare manualmente una piastrina collegata con un filo allo slot giusto?

  16. Alessandro Rosso says:

    Chiudo il contatto tra punta torcia plasma (che è isolata) con la lamiera da tagliare.

    • Livio says:

      Per cui se ti aggiungessimo il G92 che preme il tasto “Calibrate Z” pensi che basterebbe?
      Il mio intuito mi dice che salteranno fuori altri problemi che non hai analizzato e che quindi perderemo solo del tempo. Ma se vuoi ci provo.

      Però prima di iniziare (dato che anche per una modifica apparentemente cosi’ semplice di ore ce ne vogliono…) fammi il piacere di simulare almeno una volta il tutto, facendolo manualmente e dimmi che ci sei riuscito, e quanto devi attendere prima di far ripartire il GCODE.

  17. Alessandro Rosso says:

    Ok grazie
    Per il tempo comunque non è un problema perché G4 posso gestirlo dal GCode con un pos processor

  18. Alessandro Rosso says:

    Buongiorno
    Ho dovuto aggiungere un relè che mi taglia l’arco pilota in fase di azzeramento.
    Comunque funziona

    • Livio says:

      Sto tentando di aggiungere il G92 che esegue un “Calibrate Z”.
      Non è facile perché va fatto durante l’esecuzione del GCODE e questo non era previsto ma spero di riuscirci.
      Per ora ho scoperto che il G92 (con parametri) funziona già ma si deve fare attenzione a non aggiungere commenti nella stessa riga perché altrimenti da un errore.

      Appena sarò riuscito a fare qualcosa di utile ti manderò una versione di prova.

  19. Eugene says:

    Hello,
    I built two theremino MCA for gamma spectrometry and they work great when they do. At times, however, they are overtaken by the noise and show no data. Interestingly, that happens to both of my devices at the same time… The day when they work – both of them are working fine, but when they are possessed by that noise it happens to both of them as well. I suspect there is perhaps an environmental influence… may be humidity? I cannot figure it out.

  20. Eugene says:

    in addition to the previous question. I noticed that the noise is induced by increasing the voltage or me touching the detector (ground). Once the noise starts it doesn’t go away. It seems like it is a self-oscillating noise in the transistor amplifier. Perhaps reducing gain will help to eliminate this noise?

    • Livio says:

      The transistor amplifier has a configuration that can not oscillate, and can not oscillate also if it is build with wrong component values.
      Maybe there is a possibility if the transistors T3 is a darlington and not normal NPN transistor.
      By the way please check all the component values in the area C8, C9, R8, R9, R10, C10, C11, R11, R12, R13, C12.

      And also check if this area is build with short connections…

      The PCB is exactly as projected by us, or maybe it is different, with long or strange tracks ?

      The GND is well connected to the PC ?

  21. Livio says:

    Probably some points are poorly insulated, for example the welds in the BNC connectors, and discharges are generated on the high voltage.
    Maybe reducing the PMT voltage could solve this problem.
    But to understand the problem we need more data.

    What PMT tube you are using ?
    Both the devices are identical ?
    What voltage you set?
    What crystal, NaiTl?
    The PCB is our version with the integrated audio card chip on the PCB?
    The PCB is professionally produced with the solder protective layer ?
    Etc…

    • Eugene says:

      checked the welds, no problem there
      both devices are identical
      when both devices work they do work with high or low voltage(550-1100v)
      crystal NaI(Tl), R6095
      PCB is professionally made with protective layer, audio card chip is not on PCB.

      As I said, most puzzling is that periods of normal functioning and non-working always coincide – they either both work properly or they both don’t work, always at the same time. I think there’s an outside factor that cases the problem…
      I tried on two different computers, it doesn’t solve the problem.

  22. Eugene says:

    On the days when it doesn’t work, even plugging in the sound card freezes the whole computer. Plugging it without the PMT doesn’t freeze the computer.

    Also I noticed that the noise as it appears on the Theremino screen is the same as when you accidentally unplug the USB sound card before closing down Theremino MCA program.

    • Livio says:

      Maybe some USB or OS quirks?
      We are sorry but no one has encountered similar problems, so you will have to find the solution yourself with many experiments.

  23. Andrew Ro says:

    Ciao! Nella sezione IotHAL – Comunicazione radio con IotModule (ESP32) – non è presente alcun firmware per esp32. Dovrebbe essere nella cartella principale “IotModule”. Qual è il motivo?

    • theremino says:

      Ho guardato ora e nella sezione IotHal il firmware c’è
      – Apri questo link
      https://www.theremino.com/downloads/foundations#iothal
      – O se lo preferisci in inglese è questo :
      https://www.theremino.com/en/downloads/foundations#iothal

      – Scendi fino a incontrare la grande immagine dello ESP32 e i suoi PIN
      – Scendi ancora
      – I primi link IN VERDE sono la documentazione
      – Scendi ancora
      – Le tre righe IN VERDE sono il link al FIRMWARE

      Poi di seguito ci sono anche i link della applicazione IotHAL che ti servirà per configurare i PIN e comunicare col modulo.

      Tutti i nostri link si trovano sempre verso la fine di ogni sezione e sono riconoscibili per il colore di sfondo verde.

      • Andrew Ro says:

        Thanks for the quick response! The link does have a zip file. However, it does not contain firmware. There are only source texts of the program (.h files). I believe the firmware is .bin files.

        • Livio says:

          The Esp32 module must be programmed with the ArduinoIDE, as explained in our documentation.

          Perhaps there may also be other methods to program it from a BIN file, but in this case you would not be able to use them because you have to specify the network name and password before compiling and programming.

          In addition, there are many other useful parameters in the configuration file, also to be modified before recompiling and programming.

          Ultimately, using the Arduino IDE is a very convenient method, you just need the USB, you don’t need a programmer and you can also edit and recompile in a few seconds.

  24. Marco Corbetta says:

    Salve , ho caricato il programma “Theremino WiFi v1.1” sul mio sistema con 11th Gen Intel(R) Core(TM) i7-11700KF @ 3.60GHz 3.60 GHz , 32GB di ram , ssd e windows 11 aggiornato: il programma parte e visualizza i segnali poi si blocca col seguente messaggio di errore : errore di overflow …. e nei dettagli quanto segue:

    ************** Testo dell’eccezione **************
    System.OverflowException: Errore di overflow.
    in System.Drawing.Graphics.CheckErrorStatus(Int32 status)
    in System.Drawing.Graphics.DrawLine(Pen pen, Single x1, Single y1, Single x2, Single y2)
    in Theremino_WiFi.SignalGraph.UpdateChannels(PictureBox pbox)
    …..
    …..

    E’ possibile risolvere l’errore?
    Grazie per la risposta
    Marco Corbetta

    • Livio says:

      Ho lasciato solo le prime righe che sono le uniche un po’ significative.

      Il metodo giusto sarebbe:
      – Comunicare via Skype
      – Installare Visual Studio sul PC che da l’errore
      – Farmi vedere l’errore attraverso Skype e provare a correggerlo

      Cercheremo di fare qualcosa anche al buio, forse ti potrò mandare una versione di prova, ma per mandartela ci vorrà comunque Skype, altrimenti nella posta non passa.

      Cercami su skype come livio_enrico

Leave a Reply to theremino Cancel reply

Your email address will not be published.